← Go back to Info :: LinuxServer.io

Notification: Changes For 3rd Party Mod Authors

August 27, 2022 at 6:00 PM

Notifications mods


As part of our programme of work to migrate our base images to s6 v3, we now support “hybrid” mods, targeting both s6 v2 and v3. All currently supported Linuxserver base images are using s6 v3, however, older pinned images, forked versions, etc. may still be using v2. To support both cases, simply include both sets of files in your mod, the built-in mod logic will pick the appropriate files to run.

Over the next several months we will begin to migrate our downstream images to using the full v3 init process and at that point your mods will need to have a v3 component to work reliably. v2-only mods will run on v3 images for the forseeable future but we will not provide support for that configuration and you may run into timing issues.

Please see the updated mods README for details of the new mod structure and how everything fits together. If you have queries regarding how to migrate your mods please ask them on our Discord server in the #dev-talk channel.

Last updated: August 27, 2022 at 12:52 PM